Can I use ActiveMQ 5.x or later on Java 1.4

 FAQ > Using Apache ActiveMQ > Can I use ActiveMQ 5.x or later on Java 1.4

Can I use ActiveMQ 5.0 or later on Java 1.4?

Apache ActiveMQ 5.x or later is developed to run on Java 5 or later to take advantage of the new language features together with the major fact that on Java 5 the new concurrency code is faster & less buggy and requires less dependencies.

We may get around to creating a sepate distro of retrotranslated jars for 1.4 particularly if someone helps.

Until then you can just install the retrotranslator JIT in your JVM which will auto-swizzle all Java 5 bytecode to be complaint Java 1.4 bytecode using backport-util-concurrent instead of Java 5 concurrency code.

See Also

Apache ActiveMQ, ActiveMQ, ActiveMQ Artemis, Apache, the Apache feather logo, and the Apache ActiveMQ project logo are trademarks of The Apache Software Foundation. Copyright © 2019, The Apache Software Foundation. Licensed under Apache License 2.0.