What platforms does ActiveMQ Support?

ActiveMQ 5.0-5.7 supports any Java platform of JDK 5.0 or later. To run on 1.4 see these instructions. You can use ActiveMQ 4.x on Java 1.4. ActiveMQ 5.8 and later require Java 6 or higher.

ActiveMQ is based on J2EE 1.4 or later and so implements JMS 1.1 and a JCA 1.5 Resource Adaptor.

We regularly test ActiveMQ on Windows, OS X, Linux and Solaris though we're aware of folks who use AIX too.

See Also

© 2004-2011 The Apache Software Foundation.
Apache ActiveMQ, ActiveMQ, Apache, the Apache feather logo, and the Apache ActiveMQ project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
Graphic Design By Hiram