JAXB 2.0 API is being loaded from the bootstrap classloader, but this RI (xxx) needs 2.1 API

 FAQ > Errors > Exceptions > JAXB 2.0 API is being loaded from the bootstrap classloader, but this RI (xxx) needs 2.1 API

When using JDK 6 (up to JDK 6 Update 3) to run ActiveMQ you can run into this exception. There are two solutions to this:

  • Upgrade to JDK to 1.6.0_04 or above, which includes JAXB 2.1
  • Copy JAXB 2.1 to /lib/endorsed to override the API jars that ship with the JDK

Apache ActiveMQ, ActiveMQ, ActiveMQ Artemis, Apache, the Apache feather logo, and the Apache ActiveMQ project logo are trademarks of The Apache Software Foundation. Copyright © 2019, The Apache Software Foundation. Licensed under Apache License 2.0.